The EasyUpdate tool is used for manual firmware updates on site. The user installs the application on Windows and then only needs the firmware file (not included), which is obtainable here for the particular device.

Following device series and interface cards are compatible for updates:

  • PSI 800 R
  • PSI 8000 T / DT / 2U / 3U
  • PS 8000 T / DT / 2U / 3U
  • PSI 9000 (old series until 2012)
  • EL 3000
  • EL 9000
  • EL 9000 HP
  • IF-E1B / IF-E2B


Restrictions:
Updating devices is only possible with an interface card featuring a USB or RS232 port, such as IF-Ux, IF-E1B, IF-PB1 or IF-Rx! The interface card IF-G1 can not be used to update a device!

 

Minimum requirements:
PC with Windows 7 or newer, 1 GB RAM, approx. 300 MB harddrive space, 1x COM-Port or 1x USB
Device with interface card and proper cable (e.g. null modem cable, not included)

 EasySoft Update Tool (with LabView Runtime, 174 MB) *

*LabView based, installs a runtime engine and services. The services may be deactivated, if not used otherwise.



 Firmwares